预警Jenkins Script Security Plugin远程代码执行高危漏洞

2019年3月11日,监测到Jenkins官方发布安全公告披露多个安全漏洞,其中包含一个Script Security Plugin远程代码执行漏洞,风险较大。

漏洞描述

本次漏洞是针对之前修复的绕过利用,历史漏洞信息详见:https://help.aliyun.com/noticelist/articleid/1000106820.html,经阿里云云盾安全工程师分析漏洞真实可利用。建议Jenkins用户尽快处理。

涉及漏洞插件:

AppDynamics Dashboard Plugin < 1.0.15

Azure VM Agents Plugin < 0.8.1

Bitbar Run-in-Cloud Plugin < 2.70.0

Email Extension Plugin < 2.65

Groovy Plugin < 2.2

Job DSL Plugin < 1.72

Matrix Project Plugin < 1.14

OSF Builder Suite For Salesforce Commerce Cloud :: Deploy Plugin < 1.0.11

Pipeline: Groovy Plugin < 2.64

Rabbit-MQ Publisher Plugin < 1.2.0

Repository Connector Plugin < 1.2.5

Script Security Plugin < 1.54

漏洞评级

严重

安全建议

登陆jenkins插件管理后台/pluginManager/,检查插件安全升级并升级至最新版本

相关链接

https://jenkins.io/security/advisory/2019-03-06/

「点点赞赏,手留余香」

    还没有人赞赏,快来当第一个赞赏的人吧!