0°

预警Apache Log4j2 远程代码执行漏洞(CVE-2021-44228)

2021年11月24日,安全专题向Apache官方报告了Apache Log4j2远程代码执行漏洞。2021年12月10日,安全专题发现 Apache Log4j 2.15.0-rc1 版本存在漏洞绕过,请及时更新至 Apache Log4j 2.15.0 正式版本。

 

漏洞描述

Apache Log4j2是一款优秀的Java日志框架。2021年11月24日,安全专题向Apache官方报告了Apache Log4j2远程代码执行漏洞。由于Apache Log4j2某些功能存在递归解析功能,攻击者可直接构造恶意请求,触发远程代码执行漏洞。漏洞利用无需特殊配置,经安全专题验证,Apache Struts2、Apache Solr、Apache Druid、Apache Flink等均受影响。2021年12月10日,安全专题发现 Apache Log4j 2.15.0-rc1 版本存在漏洞绕过,请及时更新至 Apache Log4j 2.15.0 正式版本。本站安全专题提醒 Apache Log4j2 用户尽快采取安全措施阻止漏洞攻击。

 

漏洞评级

CVE-2021-44228 Apache Log4j 远程代码执行漏洞 严重

 

影响版本

Apache Log4j 2.x < 2.15.0

 

安全建议

1、排查应用是否引入了Apache log4j-core Jar包,若存在依赖引入,且在受影响版本范围内,则可能存在漏洞影响。请尽快升级Apache Log4j2所有相关应用到最新的 log4j-2.15.0 版本,地址 https://logging.apache.org/log4j/2.x/download.html

2、升级已知受影响的应用及组件,如 spring-boot-starter-log4j2/Apache Struts2/Apache Solr/Apache Druid/Apache Flink

3、临时缓解方案。可升级jdk版本至6u211 / 7u201 / 8u191 / 11.0.1以上,可以在一定程度上限制JNDI等漏洞利用方式。对于大于2.10版本的Log4j,可设置 log4j2.formatMsgNoLookups 为 True,或者将 JndiLookup 类从 classpath 中去除,例如 zip -q -d log4j-core-*.jar org/apache/logging/log4j/core/lookup/JndiLookup.class

 

相关链接

1、https://logging.apache.org/log4j/2.x/security.html

2、https://github.com/advisories/GHSA-jfh8-c2jp-5v3q

 

「点点赞赏,手留余香」

    还没有人赞赏,快来当第一个赞赏的人吧!