0°

预警fastjson <= 1.2.68 反序列化远程代码执行漏洞

近日,本站安全专题监测到fastjson爆发新的反序列化远程代码执行漏洞,黑客利用漏洞,可绕过autoType限制,直接远程执行任意命令攻击服务器,风险极大。

漏洞描述

fastjson采用黑白名单的方法来防御反序列化漏洞,导致当黑客不断发掘新的反序列化Gadgets类时,在autoType关闭的情况下仍然可能可以绕过黑白名单防御机制,造成远程命令执行漏洞。经研究,该漏洞利用门槛较低,可绕过autoType限制,风险影响较大。本站安全专题提醒fastjson用户尽快采取安全措施阻止漏洞攻击

影响版本

fastjson <=1.2.68

fastjson sec版本 <= sec9

安全版本

fastjson >=1.2.69

fastjson sec版本 >= sec10

安全建议

注意:较低版本升级至最新版本1.2.69可能会出现兼容性问题,建议升级至特定版本的sec10 bugfix版本

一、升级至安全版本,参考下载链接:云中心

二、fastjson加固

fastjson在1.2.68及之后的版本中引入了safeMode,配置safeMode后,无论白名单和黑名单,都不支持autoType,可一定程度上缓解反序列化Gadgets类变种攻击(关闭autoType注意评估对业务的影响)开启方法参考:https://github.com/alibaba/fastjson/wiki/fastjson_safemode

三、采用其他json处理组件替换,jackson-databind漏洞也频发,建议使用Gson

四、使用安全云防火墙紧急漏洞拦截(可申请免费试用),再升级到安全版本

安全云中心应急漏洞模块已支持对该漏洞一键检测

安全云中心已可防御此漏洞攻击

官方链接

https://github.com/alibaba/fastjson/releases/tag/1.2.69

我们会关注后续进展,请随时关注官方公告。

内容来自网络,如有侵犯到您的权益,请联系站长QQ7529997,我们将及时处理。

本站安全专题

2020.05.29

「点点赞赏,手留余香」

    还没有人赞赏,快来当第一个赞赏的人吧!